Jump to content
Sign in to follow this  
Enyby

Binary scripts with corrupted or invalid headers

Recommended Posts

Binary scripts with corrupted or invalid headers interfere with application development.
For this reason:

  1. Starting with GG 87.0, a variety of warnings and notifications are displayed ("Invalid binary script header").
  2. In future versions of GG, such scripts will not be executed.
  3. Uploading such files to the forum is blocked.
  4. All scripts that allow you to create binary scripts with damaged headers will be deleted.

You can use a script that replaces the header:

Lua header fixer (#8vs58ae4)

If this does not help, write to the author of the script.

To users of scripts: write to script authors so that they do not spoil the headers.
To script writers: Don't mess with the headers.
If you want to indicate authorship, there are messages, toasts, and other ways. The file header is not a means of self-expression.

If your encryptor / compiler has been deleted, you can remove the creation of corrupted headers from it and upload it as a new file.

Share this post


Link to post
Share on other sites

Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...