Jump to content
dfmcvn

Can't start the daemon (with root).

Recommended Posts

Hello,

I'm using Redmi Note 7 on Android 9 with Magisk (root) installed.

When I start the SW ver., it takes long time to start. And there are no promt to grant root permission for GG.

It just display the error: "Failed to run daemon. Is root installed?"

GG_logcat_r75.0_14566_9_28.log

Share this post


Link to post
Share on other sites

No root. or no root granted, Or magisk problem. Maybe you hide root.

Share this post


Link to post
Share on other sites
Posted (edited)
30 minutes ago, Enyby said:

No root. or no root granted, Or magisk problem. Maybe you hide root.

Thanks for your reply. Yes, I'm hiding root on some eWallet app. But not for GG, surely.

Root is installed and working normal since I use Greenify so much.

Is there any other way I can gain more logs for you to debug?

Edited by dfmcvn

Share this post


Link to post
Share on other sites

So turn off hiding the root.

The problem is not in the application, but in your system or root. So solve these problems.

Share this post


Link to post
Share on other sites

Update: To fix this problem,

- Open GG.

- Hide GG, then open Magisk (or any root manager).

- Patiently wait for the promt, then grant root permission for GG.

I think the problem occurs from Magisk beta (v19), not from GG itself.

Thanks for your help.

Share this post


Link to post
Share on other sites
On 17/04/2019 at 08:32, dfmcvn said:

Mise à jour: pour résoudre ce problème,

- Ouvrez GG .

- Cachez GG , puis ouvrez Magisk (ou n’importe quel gestionnaire de racine).

- Attendez patiemment l' attente , puis accordez la permission root pour GG .

Je pense que le problème vient de la version bêta de Magisk (v19), pas de GG lui-même.

Merci de votre aide.

Hey I did what you said but it does not work you can detail?

Share this post


Link to post
Share on other sites
6 hours ago, Barrobg said:

Hey I did what you said but it does not work you can detail?

What version of Magisk you are using?

I dont really have any idea why I can fix the problem.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...